Orange Pi

Устройства - Devices => Orange Pi PC => Тема начата: BoomRat от Февраль 16, 2016, 06:58:52 pm

Название: Не могу запустить '_' Opi PC
Отправлено: BoomRat от Февраль 16, 2016, 06:58:52 pm
Здравствуйте, форумчане!
Недавно заказал себе с али Orange Pi Pc.
Столкнулся с проблемой - не могу его нормально запустить.
Делал сначала всё по инструкции на сайте (http://www.orangepi.org/quickstart/start_3dd156157e45feb8b482004d81ddbe.html).
Скачал все программы, форматнул SD карту  (sony 16гб, 10 класс) и залил на неё лубунту (http://www.orangepi.org/downloadresources/orangepipc/oragepipc_4a0e8d960f7f0a52606dfaba58.html).
Подключил всё как надо и... Загорелись светодиоды тока на лан порте. Долго перетыкал все провода и о чудо, оно заработало! Загрузилась лубунта. Я там чуть полазил и решил поставить туда VNC...
После #apt-get install tightvncserver пошли какие-то загрузочки, но в конце выдало ошибку (что-то вроде time out, точно не помню). Апельсинка зависла, потом показала пустой рабочий стол. Я же, ессесна, перепугался и не найдя способа заставить её отвиснуть, выдернул провод из розетки...
 Потом я перепробовал много систем и script.bin менял и чего только я не делал... Всё время загорался лан-порт, а красный диод-нет...
 И вот с где-то 7-8 попытки я поставил ту-же лубунту и красный светодиод загорелся! Но радость моя быстро утихла, так как на телевизоре был чёрный экран. Но сигнал был, телевизор даже разрешение показывал (ниже скрины, чтоб вам понятнее).
Извините, вам запрещён просмотр содержимого спойлеров.

Перечитал много всего, но инфы о том, как это исправить так и не нашел. Кто сталкивался, помогите.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: Vital864 от Февраль 17, 2016, 07:44:55 pm
Привет, BoomRat! Ситуация немного непонятная, но кое-что можно подсказать. Во-первых, поставь девятую версию лубунты. Восьмая не поддерживает общение со script.bin. Ставь вот эту версию - https://drive.google.com/file/d/0B2ZvWXG-omrAdkd5c21WRC1TUkU. Она самая простенькая, но рабочая. Я на ней экспериментирую. И второе - форматни флешку полным, не быстрым форматированием.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: AlDemin от Февраль 17, 2016, 07:49:52 pm
Девятую не советую, это не сборка а свалка, если только ядро с модулями и фирмварями заменить на Борисовские, тогда еще ничего.
Мате или Дебиан мини.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: Vital864 от Февраль 17, 2016, 09:12:14 pm
   Я с той стороны, что я сам напоролся на восьмёрку, тысячу раз редактировал скрипт.бин, а результат был один и тот же. В девятке система опрашивает скрипт и можно понемногу разбираться с системой и экспериментировать с установками. Так хоть с места всё сдвинется.
   Вот мате ни разу не пробовал. Сань, а как по скорости, убунту мате не уступает лубунте?
Название: Re: Не могу запустить '_' Opi PC
Отправлено: AlDemin от Февраль 17, 2016, 09:52:28 pm
А как их сравнить? Двух устройств у меня нет, чтоб рядом запустить.
Не думаю, что мате много кушает это не гном 3й и не юнити.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: warik от Февраль 18, 2016, 07:25:38 pm
Так же советую потыкать разные карты памяти. Или же Low Level Format попробовать. Может быть проблема именно с картой из-за того что на неё производилась запись, а Вы её грубо говоря отключили.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: BoomRat от Март 03, 2016, 02:07:45 pm
Пробовал карточку Qumo 6 класса с Lubuntu 9. Никакого толку, даже красный диод не горит.
Возможно дело в питании? Что если подпаяться к GPIO? Никогда в жизни не паял, объясните как это делается, если не сложно.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: fvfnfh от Март 03, 2016, 02:42:04 pm
 Никогда в жизни не паял ....тогда лучше и не начинать.Для gpio есть спец.разъем,вот к нему можно и подпаяться.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: szWULBEX от Март 28, 2016, 09:30:23 am
Как я понял по собственному опыту запуска этой платы - не запускается из-за блока питания, провода питания и флешки. Необходимо 5V 2A, толстые провода от блока питания к плате и писать образ по инструкции (через специальные программы). Всё ( образы, инструкции, программы) указано на сайте Orange PC.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: Kostya127 от Апрель 02, 2016, 09:15:58 am
Помогите, схожая проблема, но решить пока не могу!
Имею OPI PC + блок питания от оф.продавца. 2-е SD карты SanDisk 16Gb 10class и Kingstone 8Gb 4класс.
Заливал образ OrangePI-PC_Ubuntu_Vivid_Mate.img.xz, взятый с https://drive.google.com/folderview?id=0B1hyW7T0dqn6fndnZTRhRm5BaW4zVDVyTGlGMWJES3Z1eXVDQzI5R1lnV21oRHFsWnVwSEU&usp=sharing (https://drive.google.com/folderview?id=0B1hyW7T0dqn6fndnZTRhRm5BaW4zVDVyTGlGMWJES3Z1eXVDQzI5R1lnV21oRHFsWnVwSEU&usp=sharing)
Заливал на обе карты и разными прогами: Под Виндой SDFormatterv4 + Win32DiskImager, в Убунту GParted + Диски.
Результат всегда один: HDMI нет сигнала, RCA - черный экран. Радиатор приклеенный к процессору слегка греется. При включении загорается красный диод на плате и горят диоды на сетевом разъеме, через несколько секунд  несколько раз мигнув гаснут. Но радиатор остается теплым. Ждал так минут 30... Все, дальше дело не идет!
Подскажите, в какую сторону копать? Script.bin подменить? Каким? ulmage?
Может имеет значение? При включении к плате подключены HDMI, RCA. Включал с беспроводной мышью и флешкой (Флешка светится, на ЮСБ питание ест)
Помогите завести его!!
Название: Re: Не могу запустить '_' Opi PC
Отправлено: VladPTZ от Апрель 02, 2016, 10:51:47 am
У меня на Lubuntu Через HDMI на телевизоре показывает http://www.orangepi.org/downloadresources/orangepipc/oragepipc_4a0e8d960f7f0a52606dfaba58.html
Название: Re: Не могу запустить '_' Opi PC
Отправлено: AlDemin от Апрель 02, 2016, 10:57:00 am
Цитировать
При включении загорается красный диод на плате и горят диоды на сетевом разъеме, через несколько секунд  несколько раз мигнув гаснут.
Это значит, что система грузиться, RCA нужно специально включать, а что подключили по HDMI?
Название: Re: Не могу запустить '_' Opi PC
Отправлено: Kostya127 от Апрель 03, 2016, 06:32:57 am
По HDMI подключаю тв Philips. Попробую установить Лубунту 080, по совету из поста выше.
Вчера пробовал андроид установить, взятый тут http://www.orangepi.org/downloadresources/orangepipc/oragepipc_6ace8597a2051c8bcf2b9e7b63.html (http://www.orangepi.org/downloadresources/orangepipc/oragepipc_6ace8597a2051c8bcf2b9e7b63.html)
То же самое, RCA выдал черный экран, но заработал HDMI, опять же черный экран! Радиатор на процессоре немного грелся.
Сколько по времени должна длиться первая загрузка?
Название: Re: Не могу запустить '_' Opi PC
Отправлено: AlDemin от Апрель 03, 2016, 10:25:19 am
По HDMI подключаю тв Philips.
не люблю филипсы - черезчур "себе на уме"
Цитировать
Попробую установить Лубунту 080, по совету из поста выше.
обе Лубунты с кучей недостатков требуют допиливания, Возьмите Мате - главное выбрать правильный script.bin - 720p60 или 720p50 филипок скорее всего скушает. Хотя для нормальной работы и у Мате нужно ядро менять.
Цитировать
Сколько по времени должна длиться первая загрузка?
Секунд через 15 должно появляться изображение, не появилось - значить не тот режим.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: Kostya127 от Апрель 04, 2016, 11:49:50 am
Ура! Запустил Мате, без каких либо танцев с бубном! Форматировал флешку и заливал образ родными средствами Убунту. Вот только экран немного не помещается, обрезан по краям! Подсовывание разных скриптбинов из образа проблему не решило. Возможно еще дело в том, что захожу под Гостем, т.к. пока не нашел клавиатуру для своего Оранжа, и поэтому не могу поменять разрешение.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: AlDemin от Апрель 04, 2016, 01:14:39 pm
Вот только экран немного не помещается, обрезан по краям!
Это надо на самом телевизоре размер настроить, любят они изображения растягивать. и края прятать.

Цитировать
и поэтому не могу поменять разрешение.
и не сможешь, разрешение настраивается один раз при старте системы - берется из script.bin и больше не меняется.
Название: Re: Не могу запустить '_' Opi PC
Отправлено: Kostya127 от Апрель 06, 2016, 02:38:02 am
Установил Debian от сюда http://www.armbian.com/ (http://www.armbian.com/) по инструкции от сюда https://youtu.be/1D4pEDFpkOk (https://youtu.be/1D4pEDFpkOk). Думаю на этом образе и остановится. К слову сказать, у меня всего 2 образа завелись, вышеуказанный Мате и Дебиан. Попытки установить Лубунту 080, 090, 100 ни к чему не привели, скорее всего скриптбин и uImage не те подсовываю.
Первые впечатления от Дебиана: Радиатор на чипе греется совсем слегка, тогда как на Мате он был горячий. Графическая среда, работает на отлично, я бы сказал "Летает", ни каких подтормаживаний и т.п., в Мате открытие любого окошка сопровождалось ~секундной задержкой!
Всем, кто откликнулся, мне помочь, огромное спасибо!
Название: Re: Не могу запустить '_' Opi PC
Отправлено: ua3prq от Апрель 06, 2016, 03:35:28 pm
Армбиан стоит на сервере больше полугода,- впечатления самые положительные. Более старые сборки Игоря трудятся уже 2 года 24/7 (но на А20 SoC).
Название: Re: Не могу запустить '_' Opi PC
Отправлено: gmonorok от Апрель 07, 2016, 08:52:20 pm
Истользую арбиан в производстве.
в сфере ИБ.
Изза размеров и питания в некоторых случаях равных нет...
но скорость......
Perl и питон в 20 (!)раз медленнеее чем на виртуалку на среднем компе..
но для моих целей хватает.
аптаймы по пару недель запросто.
ннкорректные выключения выдергивание пмталова переносит на раз.